Upgrade ezMaster

ezMaster Three-Step Upgrade

ezMaster is a software tool that allows you to manage and scale your network with convenience and flexibility. ezMaster v1.0 (c1.9) has been released featuring major improvements available to all customers. 

This page is intended to guide you through the upgrade process to v1.0 (c1.9) of ezMaster with step-by-step instructions.

The minimum version required for upgrade v0.13 (c1.8). If your version is below, you’ll first need to upgrade to v0.13 (c1.8) and check for mismatched SSID settings of your managed access points.

  Download ezMaster v0.13(c1.8)

Make sure all access points currently managed by ezMaster are upgraded to the firmware version 3.5.x (c1.9). If you have already done so, you can skip this step.

You are now ready to upgrade to ezMaster v1.0 (c1.9) and enjoy its new features. 

Click the link below to download. 

Download ezMaster v1.0(c1.9)

 
 
 

 

Step-By-Step Instructions

 STEP 1 Prepare Software for Upgrade

1. Upgrade ezMaster to v0.13
1-1. Go to ezMaster Home and check the current version( How to find? ). If below v0.13 (c1.8), you’ll first need to update to v0.13.
1-2. Go to ezMaster > Global Settings > Update ezMaster to upload the v0.13 binary file and complete the update process.

2. Check Mismatched SSID Settings and Reconfigure APs
2-1. Go to ezMaster > Global Settings > Update ezMaster, upload the ezMaster v1.0 binary file, and click the ‘Check’ button to discover access points with mismatched SSID settings.

Download ezMaster v1.0 (c1.9)

2-2. A list of access points with incompatible firmware will be presented. Go to each access point page and reconfigure its SSID settings until no more errors are present.

● Security Error
You must configure your security to open or WPA2-PSK / WPA2-Enterprise and then set the same password at the same SSID under the both 2.4GHz and 5GHz channels.
● Captive Portal
Enable the Captive Portal setting before upgrading. The guest network has been integrated into the Captive Portal and must be available.
● Duplicate SSID
Resolve any duplicate SSIDs with the same name on the 2.4GHz or 5GHz channel. Each SSID must have a unique name.
● SSID Mismatch
You have exceeded 8 set of SSIDs! Select 8 sets of SSIDs or less – and then upgrade to the ezMaster v1.0 system.
Note:EWS300AP is only selected 4 sets of SSIDs or less.
● Security Mismatch
A password conflict was detected. You must configure a password at the same SSID for both the 2.4 GHz and 5 GHz channels.
● VLAN Mismatch
A VLAN ID conflict was detected. You must configure a VLAN ID at the same SSID for both the 2.4 GHz and 5 GHz channels.

* Check that all devices are configured with a suitable SSID. All incompatibilities must be resolved before upgrade is complete.


  
 

 STEP 2 Prepare Hardware for Upgrade

Upgrade all APs to firmware version 3.5.x
1-1. Verify that all managed APs have the latest firmware version 3.5.x. To do so, proceed toezMaster > Project > Device Management > Device Config and check each device’s firmware version.

Option 1 – Manual Upgrade: Bulk update by AP model

Option 2 – One-click Update: Download to devices from EnGenius FW server

Go to ezMaster > Project > Maintenance > Bulk Update
● Upload firmware v3.5.x (c1.9) for the specific AP model
● System would display those devices that are relevant to the firmware uploaded
● Select device(s) for upgrade
● Repeat this step for all models as required

● Go to ezMaster > Global Settings > One-click update and click on “Check for updates”
● System will automatically check for new firmware versions for every model under ezMaster management
● Click “Update” to update to v3.5.x for all managed APs 

 


 
 
 

 STEP 3 Upgrade ezMaster to v1.0.19

1. Download ezMaster v1.0 (c1.9) and upgrade
1-1. Go to ezMaster > Global Settings > Update ezMaster, then upload

the ezMaster v1.0 (c1.9) binary and click ‘Upgrade’.

Download ezMaster v1.0 (c1.9)

 
Q Once I upgrade from ezMaster v0.13 (c1.8) to v1.0 (c1.9), can I use ezMaster to manage Access Points with v3.4 (c1.8) or earlier
A No. Customers should upgrade all Access Points to v3.5.x (c1.9) firmware before they use ezMaster v1.0 (c1.9).  
May I downgrade ezMaster from v1.0 (c1.9) to an early version, such as v0.13 (c1.8)?
No. Customers cannot downgrade to the older version ezMaster if they already upgraded to v1.0 (c1.9).
In my ezMaster account, I already had v3.5.x (c1.9) Access Points and v3.x (c1.8) Access Points. May I use the ezMaster v1.0.19 (c1.9) version?
No. To manage Access Points under ezMaster v1.0 (c1.9), you first need to upgrade all Access Points to v3.5.x (c1.9).
May I use WEP/WPA security under v3.5.x (c1.9) Access Points?
No. The v3.5.x (c1.9) firmware will only support WPA2-AES/WPA2-Enterprise security.
Which models support ezMaster v1.0 (c1.9)?
EWS300AP, EWS310AP, EWS350AP, EWS360AP, EWS370AP, EWS371AP, EWS500AP, EWS510AP, EWS550AP, EWS650AP, EWS660AP, EWS860AP, EWS870AP, EWS871AP, ENS620EXT, ENH1350EXT, EAP1250, EAP1300, and EAP1300EXT. 
Note: The EAP2200 and EMD1 models will be supported by ezMaster v1.0 via upgrading v3.5.x AP firmware by the end of September.
Are any new functions supported under ezMaster v1.0 (c1.9)?
Yes. The ezMaster v1.0 (c1.9) is a structured changed on supporting captive portal per SSID with NAT mode and Bridge mode, Wi-Fi scheduler, and multi-tenant account.

Release Notes ezMaster

 

 ezM v0.13 (c1.8) ezM v1.0 (c1.9)
ezMaster Release Notes c1.8ezMaster Release Notes c1.9